Backflow Survey Introduction

Link to Backflow Survey

There have been issues with some browsers allowing fillable PDF's in their default viewers. If you are experiencing difficulties submitting the survey (see above link), please follow the appropriate instructions below.

Internet Explorer

If you receive a security alert at the top of the PDF, “Add host to Privileged Locations” from the Options button. This should prevent the issue from happening again for the current domain. Since IE uses Adobe Reader as its default PDF viewer, this should be all that needs to be done.


The new version of Firefox uses its built-in PDF viewer by default and it doesn’t have the capability to view auto-filled forms. So Firefox users will need to set their default PDF viewer to use Adobe Reader.

To switch from the built-in PDF viewer to another PDF viewer:

  1. At the top of the Firefox window, click on the Firefox button and then select OptionsAt the top of the Firefox window, click on the Tools menu and then select OptionsOn the menu bar, click on the Firefox menu and select Preferences...At the top of the Firefox window, click on the Edit menu and select Preferences
  2. Select the Applications panel.
  3. Find Portable Document Format (PDF) in the list and click on it to select it.
  4. Click on the drop-down arrow in the Action column for the above entry and select the PDF viewer you wish to use.
    pdf firefox.JPG
  5. Click OK to close the Options window.


To change the default PDF Viewer in Chrome, enter chrome:plugins in the address bar and click Disable underneath the entry for “Chrome PDF Viewer.” The Adobe Reader plug-in will automatically be enabled, if you have it installed. The following link gives more information if needed:

Thank you for your patience.